PlayStation 5 will not support games for PS3 and older Sony consoles

PlayStation 5 will not support games for PS3 and older Sony consoles

At the last presentation, Sony finally answered the question that many people are worried about – backwards compatibility.

Recall, the Sony itself said that PS5 can accurately run about a hundred best games for PS4 and almost certainly many other projects for the past generation of PlayStation. Now we can confidently say that the vast majority of games for PS4 will run on PS5. This was stated by Famitsu resource in an interview with the CEO of PlayStation. To be more precise, Sony has already tested thousands of games for PS4 on PS5, and 99% of them worked perfectly.

In addition, a journalist from the resource asked Jim Ryan about compatibility with older generations of consoles. Earlier there were rumors that PS5 could still get support for all generations of PlayStation 5 games.

Unfortunately, you can forget about it. Ryan said that by focusing on new technology for PlayStation 5, the engineers were unable to implement backward compatibility with older generations of consoles.


No more posts
No more posts